Mac Info

ファイル名を自動提案してくれるmacOS 27。Finderの新機能まとめ

macOS 27 Golden Gateのデスクトップ。ファイル名の自動提案やウィジェットの縦向き特大サイズへの対応など、日々の使い勝手を向上させるさまざまな新機能が追加されています

ファイルやフォルダの内容に応じて名前を自動提案

 ファイルやフォルダには、あとから見ても内容が分かる名前を付けておきたいものです。しかし、適切な名前を考えたり、変更したりするのは、数が多いほど面倒です。

 macOS 27 Golden Gate(以下、macOS 27)では、こうした手間を減らす新機能が追加されました。

 Finderでファイルやフォルダを選択し、[return]キーを押して名前を編集できる状態にしたら、ポインタを名前の上に重ねてみましょう。

 すると、内容に応じた名前の候補がポップアップで表示され、クリックするだけで変更できます。

 画像なら写っているもの、PDFなどの書類なら記載された内容をもとに名前を提案してくれるため、適切な名前を簡単に付けられます。

 この機能はFinderだけでなく、「テキストエディット」などのアプリでも利用できます。

 新規書類を保存する際に内容に応じたファイル名が提案されるほか、保存前の書類に内容を入力すると、タイトルバーの「名称未設定」が内容に応じた名前の候補に変わります。

 ちなみに、iPhoneなどからAirDropで受け取ったファイルにも、確認なしで自動的に名前が付けられる場合があります。

 自分で名前を付けたい場合は、Finderの[設定]を開き、[一般]にある[ファイル名を提案]のチェックを外せば、この機能を無効にできます。

ファイル名を編集できる状態にしてポインタを重ねると、内容に応じた名前の候補が表示されます。候補をクリックするだけで、その名前に変更できます
フォルダ名も同様に、フォルダ内のファイルの内容に応じた名前が提案されます
新規書類を保存する際のダイアログでも、書類の内容に応じたファイル名が提案されます
「テキストエディット」などで新規書類に内容を入力すると、タイトルバーに表示される「名称未設定」が、入力内容を反映したファイル名に自動的に変わります
ファイル名の提案が不要な場合は、Finderの[設定]→[一般]にある[ファイル名を提案]のチェックを外せば、この機能を無効にできます

カラム表示の列幅を自動で調整

 Finderのウインドウをカラム表示にしていると、列の幅が足りず、ファイル名が途中で切れてしまうことがあります。

 これまではカラムの区切り線をドラッグしたり、ダブルクリックしたりして幅を調整する必要がありました。

 また、[option]キーを押しながらドラッグすれば以降のカラムにも同じ幅を適用できますが、いずれも手動で操作しなければなりません。

 macOS 27では、こうした手間を省ける新しい設定オプションが追加されました。

 ウインドウ内で副ボタンクリック(右クリック、または[control]キー+クリック)して[表示オプションを表示]を選び、[ファイル名に合わせて列のサイズを調整]にチェックを入れてみましょう。

 すると、各列の幅が、その列で最も長いファイル名に合わせて自動的に調整されるため、ファイル名の長さに応じて手動で幅を変更する必要がなくなります。

ウインドウ内で副ボタンクリックして[表示オプションを表示]を選びます。[表示]メニューから[表示オプションを表示]を選択することも可能です
オプションウインドウにある[ファイル名に合わせて列のサイズを調整]にチェックを入れます
ファイル名に合わせて、自動的に列幅が変化します。元の幅に戻したいときは、チェックを外せばOKです
カラムの区切り線を副ボタンクリックすると、[このカラムのサイズを調整][すべてのカラムのサイズを個別に設定][すべてのカラムを同じサイズに設定]が選択できます

コピーした画像やテキストをFinderに直接ペースト

 たとえば、SafariでWebページを閲覧していて、ページ内の画像をデスクトップやフォルダに保存したい場合、どうしていますか?

 これまではWebページから画像をドラッグ&ドロップしたり、いったん「プレビュー」などのアプリを使って保存したりする必要がありました。

 しかし、macOS 27では、アプリでコピーした画像やテキストを、デスクトップやウインドウに直接ペーストできるようになりました。

 操作は通常のコピー&ペーストと同じです。アプリ上で[command]+[C]キーを押してコピーし、保存先となるデスクトップやFinderのウインドウを開いて[command]+[V]キーを押すだけです。

 もちろん、ショートカットキーを使わず、[編集]メニューから[コピー]や[項目をペースト]を選んでもかまいません。

 ペーストした画像はPNGやJPEG形式などの画像ファイルとして、テキストは「.textClipping」形式のファイルとして保存されます。

Safariでコピーしたテキストをデスクトップにペーストすると、「.textClipping」形式のファイルとして保存されます
画像も同様に、コピーしたものをデスクトップなどに直接ペーストできます

デスクトップウィジェットに縦長の特大サイズが登場

 デスクトップに配置したウィジェットは、副ボタンクリックして表示されるメニューからサイズを変更できますが、macOS 27ではウィジェットによっては新たに縦向きの「特大」サイズを選べるようになりました。

 「天気」や「カレンダー」、「リマインダー」など、情報量の多いウィジェットをより大きく表示できるため、内容をひと目で確認しやすくなります。

 特に大画面の外部ディスプレイを使っている場合は、複数のウィジェットを大きく配置し、デスクトップをちょっとしたダッシュボードとして活用するのもよいでしょう。

「天気」ウィジェットで[特大(縦向き)]を選択すると、9日間の天気予報を含む詳しい気象情報を縦長で表示できます
「カレンダー」など、ウィジェットによっては縦向きと横向きの2種類の特大サイズを選べます

デスクトップウィジェットがリアルタイムで更新

 デスクトップに配置したウィジェットの情報が更新されておらず、アプリと表示内容が食い違って困ったことはないでしょうか。

 これまではウィジェットの更新に時間がかかることがありましたが、macOS 27では、対応するアプリが開いている間、その内容がウィジェットにもリアルタイムで反映されるようになりました。

 これにより、アプリ側で情報が変更されても、ウィジェットの更新を待つことなく、デスクトップ上で最新の情報を確認できます。

たとえば「メモ」のウィジェットでは、編集した内容がリアルタイムでウィジェットに反映されます

Liquid Glassの見た目をスライダーで調整

 macOS 26 Tahoe(以下、macOS 26)で導入されたLiquid Glassはガラスのような透明感が特徴のデザインですが、背景が透けることで文字が読みにくいと感じる人もいるでしょう。

 こうした見づらさを軽減するため、macOS 27では「システム設定」の[外観]にLiquid Glassの見た目を調整するスライダーが追加されました。

 macOS 26では「クリア」と「色合い調整」の2種類から選ぶ方式でしたが、macOS 27ではスライダーを使って、その中間の状態も細かく調整できるようになっています。

 ただし、調整の対象となるのは、メニューやコントロールセンター、通知センター、Spotlight、ツールバー、サイドバーなどの透明度で、メニューバーやDockの見た目はほとんど変わりません。

 なお、画面全体の透明感を抑えたい場合は、従来通り「システム設定」の[アクセシビリティ]→[ディスプレイ]にある[透明度を下げる]をオンにしましょう。

「システム設定」の[外観]にある[Liquid Glass]のスライダーで透明度を調整できます。スライダーの上に表示されるプレビューで調整後の見た目を確認できます
プレビューをスクロールすれば、別の背景で透明度を確認できます

壁紙やウインドウのデザインにも細かな変更

 ここまでFinderやデスクトップの主な新機能を紹介してきましたが、macOS 27では、このほかにもさまざまな変更が加えられています。

 たとえば、壁紙には「Golden Gate」というOS名にちなみ、サンフランシスコのゴールデンゲート・ブリッジの風景が追加され、「日没」や「夕方」、「夜」といった時間帯ごとの壁紙が利用できます。

 また、Finderウインドウでは、macOS 26で外枠とサイドバーの間にあったわずかな隙間がなくなり、サイドバーがウインドウの端まで広がるようになりました。

 さらに、アプリによって微妙に異なっていたウインドウの角の丸みも統一されるなど、デザインの細部が見直されています。

 macOS 27の最大の目玉は、2026年10月中に日本語対応が予定されている「Siri AI」ですが、実は今回紹介したような身近な新機能のほうが、日々の操作で便利さを実感できる場面も少なくありません。

 macOS 27にアップグレードしたら、さっそく試してみてください。

「システム設定」の[壁紙]では、「ゴールデンゲートの日没」「昼のゴールデンゲート」「夕方のゴールデンゲート」「夜のゴールデンゲート」から、時間帯ごとに異なる風景を選べます
macOS 26(図左)ではFinderウインドウの外枠とサイドバーの間にわずかな隙間がありましたが、macOS 27(図右)ではその隙間がなくなり、サイドバーがウインドウの端まで広がっています
macOS 26(図左)では「テキストエディット」と「計算機」など、アプリによってウインドウの角の丸みが異なっていましたが、macOS 27(図右)では統一されています